Sharing files is out of order

Skyfish
7 minutes

Update

Resolved

Shared links work again. The error was only for sharing one single file and was fixed.

May 7th, 2019 09:23 CEST
Investigating

Shared links are unavailable at the moment. The link is made but it does not work.

May 7th, 2019 09:17 CEST